using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0|[1-9]{1,3})([.,][1-9]{1,3})?$";
string input = @"0
9
999
9999
99999
0.9
0.0
0.99
0,999
0.9999
99,999
999.999
9999.999
999.9999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}