#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)Principal Core.*?\bMac Domain: (\S+)"
Local $sString = "Principal Core Te1/1/0:" & @CRLF & _
" DS 0 controller: 1/0/2 (profile 200, DOCSIS)" & @CRLF & _
" DS 1 controller: NA" & @CRLF & _
" US 0 controller: 1/0/0 (profile 0, DOCSIS)" & @CRLF & _
" US 1 controller: NA" & @CRLF & _
" Mac Domain: Ca1/0/0" & @CRLF & _
"" & @CRLF & _
"Auxiliary Core Te1/1/6:" & @CRLF & _
" DS 0 controller: NA" & @CRLF & _
" DS 1 controller: NA" & @CRLF & _
" US 0 controller: NA" & @CRLF & _
" US 1 controller: NA" & @CRLF & _
" Mac Domain: NA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")