# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Principal Core.*?\bMac Domain: (\S+)"
test_str = ("Principal Core Te1/1/0:\n"
" DS 0 controller: 1/0/2 (profile 200, DOCSIS)\n"
" DS 1 controller: NA\n"
" US 0 controller: 1/0/0 (profile 0, DOCSIS)\n"
" US 1 controller: NA\n"
" Mac Domain: Ca1/0/0\n\n"
"Auxiliary Core Te1/1/6:\n"
" DS 0 controller: NA\n"
" DS 1 controller: NA\n"
" US 0 controller: NA\n"
" US 1 controller: NA\n"
" Mac Domain: NA")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.