import Foundation
let pattern = #"Principal Core.*?\bMac Domain: (\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Principal Core Te1/1/0:
DS 0 controller: 1/0/2 (profile 200, DOCSIS)
DS 1 controller: NA
US 0 controller: 1/0/0 (profile 0, DOCSIS)
US 1 controller: NA
Mac Domain: Ca1/0/0
Auxiliary Core Te1/1/6:
DS 0 controller: NA
DS 1 controller: NA
US 0 controller: NA
US 1 controller: NA
Mac Domain: NA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)