// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)Principal Core.*?\bMac Domain: (\S+)").unwrap();
let string = "Principal Core Te1/1/0:
DS 0 controller: 1/0/2 (profile 200, DOCSIS)
DS 1 controller: NA
US 0 controller: 1/0/0 (profile 0, DOCSIS)
US 1 controller: NA
Mac Domain: Ca1/0/0
Auxiliary Core Te1/1/6:
DS 0 controller: NA
DS 1 controller: NA
US 0 controller: NA
US 1 controller: NA
Mac Domain: NA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}