$re = '/Principal Core.*?\bMac Domain: (\S+)/ms';
$str = 'Principal Core Te1/1/0:
DS 0 controller: 1/0/2 (profile 200, DOCSIS)
DS 1 controller: NA
US 0 controller: 1/0/0 (profile 0, DOCSIS)
US 1 controller: NA
Mac Domain: Ca1/0/0
Auxiliary Core Te1/1/6:
DS 0 controller: NA
DS 1 controller: NA
US 0 controller: NA
US 1 controller: NA
Mac Domain: NA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);