#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(\.\w+)+$"
Local $sString = "aaa.bbb" & @CRLF & _
"aaa.bbb.ccc" & @CRLF & _
"aaa.bbb.ccc.ddd" & @CRLF & _
"" & @CRLF & _
".aaa" & @CRLF & _
"aaa." & @CRLF & _
".aaa." & @CRLF & _
"aaa.bbb." & @CRLF & _
"aaa.bbb.ccc." & @CRLF & _
"aaa..bbb...ccc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")