$re = '/^\w+(\.\w+)+$/m';
$str = 'aaa.bbb
aaa.bbb.ccc
aaa.bbb.ccc.ddd
.aaa
aaa.
.aaa.
aaa.bbb.
aaa.bbb.ccc.
aaa..bbb...ccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);