package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(\.\w+)+$`)
var str = `aaa.bbb
aaa.bbb.ccc
aaa.bbb.ccc.ddd
.aaa
aaa.
.aaa.
aaa.bbb.
aaa.bbb.ccc.
aaa..bbb...ccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}