# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\bhttps:\\/\\/|\.ingest\.sentry\.io\\/)(*SKIP)(*F)|./*/gm;t' <<< "https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/"