use strict;
my $str = 'https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/';
my $regex = qr/(\bhttps:\/\/|\.ingest\.sentry\.io\/)(*SKIP)(*F)|./mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";