$re = '/(\bhttps:\/\/|\.ingest\.sentry\.io\/)(*SKIP)(*F)|./m';
$str = 'https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;