import Foundation
let pattern = #"(\bhttps:\/\/|\.ingest\.sentry\.io\/)(*SKIP)(*F)|."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)