using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Id\W+(?<id>\d+)\D+groupId\W+(?<groupid>\w+)";
string input = @"Id"":""123456"",""string"",""groupId"":""AB123""}]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}