$re = '/Id\W+(?<id>\d+)\D+groupId\W+(?<groupid>\w+)/m';
$str = 'Id":"123456","string","groupId":"AB123"}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);