// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Id\W+(?<id>\d+)\D+groupId\W+(?<groupid>\w+)").unwrap();
let string = "Id\":\"123456\",\"string\",\"groupId\":\"AB123\"}]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}