re = /Id\W+(?<id>\d+)\D+groupId\W+(?<groupid>\w+)/m
str = 'Id":"123456","string","groupId":"AB123"}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end