package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Id\W+(?<id>\d+)\D+groupId\W+(?<groupid>\w+)`)
var str = `Id":"123456","string","groupId":"AB123"}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}