#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![a-zA-Z0-9/+=])(?=(?:[A-Z0-9/+=]*[a-z]){3})(?=(?:[a-z0-9/+=]*[A-Z]){3})(?=(?:[a-zA-Z/+=]*[0-9]){3})(?:(?=[a-zA-Z0-9/+]*(?![a-zA-Z0-9/+=]))|(?=(?:[a-zA-Z0-9/+]*=){2}))[a-zA-Z0-9/+=]+"
Local $sString = "cGFkZGluZyB3aXRoIG51bWJlcnMgeWF5cw==" & @CRLF & _
"SomeVariableName=123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")