$re = '/(?<![a-zA-Z0-9/+=])(?=(?:[A-Z0-9/+=]*[a-z]){3})(?=(?:[a-z0-9/+=]*[A-Z]){3})(?=(?:[a-zA-Z/+=]*[0-9]){3})(?:(?=[a-zA-Z0-9/+]*(?![a-zA-Z0-9/+=]))|(?=(?:[a-zA-Z0-9/+]*=){2}))[a-zA-Z0-9/+=]+/m';
$str = 'cGFkZGluZyB3aXRoIG51bWJlcnMgeWF5cw==
SomeVariableName=123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);