re = /(?<![a-zA-Z0-9\/+=])(?=(?:[A-Z0-9\/+=]*[a-z]){3})(?=(?:[a-z0-9\/+=]*[A-Z]){3})(?=(?:[a-zA-Z\/+=]*[0-9]){3})(?:(?=[a-zA-Z0-9\/+]*(?![a-zA-Z0-9\/+=]))|(?=(?:[a-zA-Z0-9\/+]*=){2}))[a-zA-Z0-9\/+=]+/m
str = 'cGFkZGluZyB3aXRoIG51bWJlcnMgeWF5cw==
SomeVariableName=123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end