import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![a-zA-Z0-9/+=])(?=(?:[A-Z0-9/+=]*[a-z]){3})(?=(?:[a-z0-9/+=]*[A-Z]){3})(?=(?:[a-zA-Z/+=]*[0-9]){3})(?:(?=[a-zA-Z0-9/+]*(?![a-zA-Z0-9/+=]))|(?=(?:[a-zA-Z0-9/+]*=){2}))[a-zA-Z0-9/+=]+";
final String string = "cGFkZGluZyB3aXRoIG51bWJlcnMgeWF5cw==\n"
+ "SomeVariableName=123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}