using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-zA-Z0-9/+=])(?=(?:[A-Z0-9/+=]*[a-z]){3})(?=(?:[a-z0-9/+=]*[A-Z]){3})(?=(?:[a-zA-Z/+=]*[0-9]){3})(?:(?=[a-zA-Z0-9/+]*(?![a-zA-Z0-9/+=]))|(?=(?:[a-zA-Z0-9/+]*=){2}))[a-zA-Z0-9/+=]+";
string input = @"cGFkZGluZyB3aXRoIG51bWJlcnMgeWF5cw==
SomeVariableName=123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}