import re
regex = re.compile(r"\b((\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\b", flags=re.MULTILINE)
test_str = ("192.168.1.1\n"
"256.1.0.255\n"
"0.0.0.0\n"
"255.255.255.255\n"
"009.009.009.009\n"
"109.109.9.0\n"
"55.255.255.255\n"
"0.99.199.249\n"
"0.19.199.255\n"
"A.99.19.199.255.100.0.0.255\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")