re = /\b((\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\b/m
str = '192.168.1.1
256.1.0.255
0.0.0.0
255.255.255.255
009.009.009.009
109.109.9.0
55.255.255.255
0.99.199.249
0.19.199.255
A.99.19.199.255.100.0.0.255
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end