// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b((\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\b").unwrap();
let string = "192.168.1.1
256.1.0.255
0.0.0.0
255.255.255.255
009.009.009.009
109.109.9.0
55.255.255.255
0.99.199.249
0.19.199.255
A.99.19.199.255.100.0.0.255
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}