using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[video=youtube_share;([^\]]+)\]([^\[]+)\[\/video\]";
string substitution = @"[media=youtube]\1[/media]";
string input = @"[video=youtube_share;4cECcwNXMRM]http://youtu.be/4cECcwNXMRM[/video]";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}