const regex = /\[video=youtube_share;([^\]]+)\]([^\[]+)\[\/video\]/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[video=youtube_share;([^\\]]+)\\]([^\\[]+)\\[\\\/video\\]', 'si')
const str = `[video=youtube_share;4cECcwNXMRM]http://youtu.be/4cECcwNXMRM[/video]`;
const subst = `[media=youtube]\1[/media]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);