$re = '/\[video=youtube_share;([^\]]+)\]([^\[]+)\[\/video\]/siU';
$str = '[video=youtube_share;4cECcwNXMRM]http://youtu.be/4cECcwNXMRM[/video]';
$subst = "[media=youtube]\1[/media]";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;