package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?siU)\[video=youtube_share;([^\]]+)\]([^\[]+)\[\/video\]`)
var str = []byte(`[video=youtube_share;4cECcwNXMRM]http://youtu.be/4cECcwNXMRM[/video]`)
var substitution = []byte("[media=youtube]\1[/media]")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}