using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((build|chore|ci|docs|fix|perf|refactor|revert|style|test)(\([\w-]*\))?:|[π¨β‘οΈπ₯πποΈππππβ
ποΈπππ¨π§πβ¬οΈβ¬οΈππ·πβ»οΈββπ§π¨πβοΈπ©βͺοΈππ¦οΈπ½οΈπππ±βΏοΈπ‘π»π¬ποΈπππ₯πΈποΈπ±π€‘π₯ππΈβοΈποΈπ·οΈπ±π©π₯
π«ποΈππ©Ήπ§β°οΈπ§ͺππ©Ίπ§±π§βπ»πΈπ§΅π¦Ί])";
string input = @"build: message
fix(scope): message
π₯message
feat: ABC-123 message
feat: message
β¨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}