re = /^((build|chore|ci|docs|fix|perf|refactor|revert|style|test)(\([\w-]*\))?:|[π¨β‘οΈπ₯πποΈππππβ
ποΈπππ¨π§πβ¬οΈβ¬οΈππ·πβ»οΈββπ§π¨πβοΈπ©βͺοΈππ¦οΈπ½οΈπππ±βΏοΈπ‘π»π¬ποΈπππ₯πΈποΈπ±π€‘π₯ππΈβοΈποΈπ·οΈπ±π©π₯
π«ποΈππ©Ήπ§β°οΈπ§ͺππ©Ίπ§±π§βπ»πΈπ§΅π¦Ί])/m
str = 'build: message
fix(scope): message
π₯message
feat: ABC-123 message
feat: message
β¨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end