const regex = /^((build|chore|ci|docs|fix|perf|refactor|revert|style|test)(\([\w-]*\))?:|[π¨β‘οΈπ₯πποΈππππβ
ποΈπππ¨π§πβ¬οΈβ¬οΈππ·πβ»οΈββπ§π¨πβοΈπ©βͺοΈππ¦οΈπ½οΈπππ±βΏοΈπ‘π»π¬ποΈπππ₯πΈποΈπ±π€‘π₯ππΈβοΈποΈπ·οΈπ±π©π₯
π«ποΈππ©Ήπ§β°οΈπ§ͺππ©Ίπ§±π§βπ»πΈπ§΅π¦Ί])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((build|chore|ci|docs|fix|perf|refactor|revert|style|test)(\\([\\w-]*\\))?:|[π¨β‘οΈπ₯πποΈππππβ
ποΈπππ¨π§πβ¬οΈβ¬οΈππ·πβ»οΈββπ§π¨πβοΈπ©βͺοΈππ¦οΈπ½οΈπππ±βΏοΈπ‘π»π¬ποΈπππ₯πΈποΈπ±π€‘π₯ππΈβοΈποΈπ·οΈπ±π©π₯
π«ποΈππ©Ήπ§β°οΈπ§ͺππ©Ίπ§±π§βπ»πΈπ§΅π¦Ί])', 'gm')
const str = `build: message
fix(scope): message
π₯message
feat: ABC-123 message
feat: message
β¨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}