import re
regex = re.compile(r"^((build|chore|ci|docs|fix|perf|refactor|revert|style|test)(\([\w-]*\))?:|[π¨β‘οΈπ₯πποΈππππβ
ποΈπππ¨π§πβ¬οΈβ¬οΈππ·πβ»οΈββπ§π¨πβοΈπ©βͺοΈππ¦οΈπ½οΈπππ±βΏοΈπ‘π»π¬ποΈπππ₯πΈποΈπ±π€‘π₯ππΈβοΈποΈπ·οΈπ±π©π₯
π«ποΈππ©Ήπ§β°οΈπ§ͺππ©Ίπ§±π§βπ»πΈπ§΅π¦Ί])", flags=re.MULTILINE)
test_str = ("build: message\n"
"fix(scope): message\n\n"
"π₯message\n"
"feat: ABC-123 message\n"
"feat: message\n"
"β¨: message\n"
"feat : ABC-123 message\n"
"feat!: message\n"
"feat(scope)!: message\n"
"feat(scope-scope)!: message\n"
"feat(scope scope)!: message\n"
"feat(scope): ABC-123 message\n"
"feat(scope): message\n"
"feat(scope): ABC-123 message\n"
"feat(scope-scope): ABC-123 message\n"
"feat(scope scope): ABC-123 message")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")