use strict;
my $str = 'Hello World!The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.
Building paragraphs can be like building a skyscraper: there must be a well-planned foundation that supports what you are building.
Any cracks, inconsistencies, or other corruptions of the foundation can cause your whole paper to crumble.
The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.';
my $regex = qr/([a-zA-Z! ,;“”.\-:]+(\n|$)){3}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}