// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z! ,;“”.\-:]+(\n|$)){3}").unwrap();
let string = "Hello World!The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.
Building paragraphs can be like building a skyscraper: there must be a well-planned foundation that supports what you are building.
Any cracks, inconsistencies, or other corruptions of the foundation can cause your whole paper to crumble.
The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}