# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z! ,;“”.\-:]+(\n|$)){3}"
test_str = ("Hello World!The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.\n"
" There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped. \n"
" Building paragraphs can be like building a skyscraper: there must be a well-planned foundation that supports what you are building.\n"
"Any cracks, inconsistencies, or other corruptions of the foundation can cause your whole paper to crumble.\n"
"The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.\n"
"There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.