import re
regex = re.compile(r"(?<Command>\/(?:.|\n(?:\t| +).)*$)", flags=re.MULTILINE)
test_str = ("/run attribute 0 \"Hello, World!\" idNameWoo true [0, 0] minecraft:grass_block run time set 0\n"
"/multiline\n"
" attribute\n"
" 0\n"
" \"Hello, World!\"\n"
" idNameWoo\n"
" true\n"
" [0, 0]\n"
" minecraft:grass_block\n"
" run time set 0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")