#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^<[^'"\d{vV;<$]+$"
Local $sString = "<?php" & @CRLF & _
"error_reporting(~E_NOTICE)&" & @CRLF & _
"define(A,a.chr(E_COMPILE_ERROR-E_NOTICE+E_WARNING))&define(B,getopt(A,[])[a])&print_r(array_chunk(" & @CRLF & _
"array_slice(" & @CRLF & _
"array_merge(" & @CRLF & _
"range(E_ERROR,B)" & @CRLF & _
",range(E_WARNING*B,E_ERROR+B)" & @CRLF & _
",range(E_WARNING*B+E_ERROR,(E_WARNING+E_ERROR)*B)" & @CRLF & _
",range(E_PARSE*B,+E_ERROR+(E_WARNING+E_ERROR)*B)" & @CRLF & _
",range(E_PARSE*B+E_ERROR,(E_PARSE+E_ERROR)*B)" & @CRLF & _
",range((E_PARSE+E_WARNING)*B,+E_ERROR+(E_PARSE+E_ERROR)*B)" & @CRLF & _
",range((E_PARSE+E_WARNING)*B+E_ERROR,(E_NOTICE-E_ERROR)*B)" & @CRLF & _
",range(E_NOTICE*B,+E_ERROR+(E_NOTICE-E_ERROR)*B)" & @CRLF & _
",range(E_NOTICE*B+E_ERROR,(E_NOTICE+E_ERROR)*B)" & @CRLF & _
",range((E_NOTICE+E_WARNING)*B,E_ERROR+(E_NOTICE+E_ERROR)*B)" & @CRLF & _
",range((E_NOTICE+E_WARNING)*B+E_ERROR,(E_NOTICE+E_WARNING+E_ERROR)*B)" & @CRLF & _
",range((E_NOTICE+E_PARSE)*B,E_ERROR+(E_NOTICE+E_WARNING+E_ERROR)*B)" & @CRLF & _
",range((E_NOTICE+E_PARSE)*B+E_ERROR,(E_NOTICE+E_PARSE+E_ERROR)*B)" & @CRLF & _
",range((E_CORE_ERROR-E_WARNING)*B,E_ERROR+(E_NOTICE+E_PARSE+E_ERROR)*B)" & @CRLF & _
",range((E_CORE_ERROR-E_WARNING)*B+E_ERROR,(E_CORE_ERROR-E_ERROR)*B)" & @CRLF & _
")" & @CRLF & _
",B-B,B*B" & @CRLF & _
"),B)" & @CRLF & _
")" & @CRLF & _
"?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")