use strict;
my $str = '<?php
error_reporting(~E_NOTICE)&
define(A,a.chr(E_COMPILE_ERROR-E_NOTICE+E_WARNING))&define(B,getopt(A,[])[a])&print_r(array_chunk(
array_slice(
array_merge(
range(E_ERROR,B)
,range(E_WARNING*B,E_ERROR+B)
,range(E_WARNING*B+E_ERROR,(E_WARNING+E_ERROR)*B)
,range(E_PARSE*B,+E_ERROR+(E_WARNING+E_ERROR)*B)
,range(E_PARSE*B+E_ERROR,(E_PARSE+E_ERROR)*B)
,range((E_PARSE+E_WARNING)*B,+E_ERROR+(E_PARSE+E_ERROR)*B)
,range((E_PARSE+E_WARNING)*B+E_ERROR,(E_NOTICE-E_ERROR)*B)
,range(E_NOTICE*B,+E_ERROR+(E_NOTICE-E_ERROR)*B)
,range(E_NOTICE*B+E_ERROR,(E_NOTICE+E_ERROR)*B)
,range((E_NOTICE+E_WARNING)*B,E_ERROR+(E_NOTICE+E_ERROR)*B)
,range((E_NOTICE+E_WARNING)*B+E_ERROR,(E_NOTICE+E_WARNING+E_ERROR)*B)
,range((E_NOTICE+E_PARSE)*B,E_ERROR+(E_NOTICE+E_WARNING+E_ERROR)*B)
,range((E_NOTICE+E_PARSE)*B+E_ERROR,(E_NOTICE+E_PARSE+E_ERROR)*B)
,range((E_CORE_ERROR-E_WARNING)*B,E_ERROR+(E_NOTICE+E_PARSE+E_ERROR)*B)
,range((E_CORE_ERROR-E_WARNING)*B+E_ERROR,(E_CORE_ERROR-E_ERROR)*B)
)
,B-B,B*B
),B)
)
?>';
my $regex = qr/^<[^'"\d{vV;<$]+$/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}