import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<[^'\"\\d\\{vV;<$]+$";
final String string = "<?php\n"
+ "error_reporting(~E_NOTICE)&\n"
+ "define(A,a.chr(E_COMPILE_ERROR-E_NOTICE+E_WARNING))&define(B,getopt(A,[])[a])&print_r(array_chunk(\n"
+ "array_slice(\n"
+ "array_merge(\n"
+ "range(E_ERROR,B)\n"
+ ",range(E_WARNING*B,E_ERROR+B)\n"
+ ",range(E_WARNING*B+E_ERROR,(E_WARNING+E_ERROR)*B)\n"
+ ",range(E_PARSE*B,+E_ERROR+(E_WARNING+E_ERROR)*B)\n"
+ ",range(E_PARSE*B+E_ERROR,(E_PARSE+E_ERROR)*B)\n"
+ ",range((E_PARSE+E_WARNING)*B,+E_ERROR+(E_PARSE+E_ERROR)*B)\n"
+ ",range((E_PARSE+E_WARNING)*B+E_ERROR,(E_NOTICE-E_ERROR)*B)\n"
+ ",range(E_NOTICE*B,+E_ERROR+(E_NOTICE-E_ERROR)*B)\n"
+ ",range(E_NOTICE*B+E_ERROR,(E_NOTICE+E_ERROR)*B)\n"
+ ",range((E_NOTICE+E_WARNING)*B,E_ERROR+(E_NOTICE+E_ERROR)*B)\n"
+ ",range((E_NOTICE+E_WARNING)*B+E_ERROR,(E_NOTICE+E_WARNING+E_ERROR)*B)\n"
+ ",range((E_NOTICE+E_PARSE)*B,E_ERROR+(E_NOTICE+E_WARNING+E_ERROR)*B)\n"
+ ",range((E_NOTICE+E_PARSE)*B+E_ERROR,(E_NOTICE+E_PARSE+E_ERROR)*B)\n"
+ ",range((E_CORE_ERROR-E_WARNING)*B,E_ERROR+(E_NOTICE+E_PARSE+E_ERROR)*B)\n"
+ ",range((E_CORE_ERROR-E_WARNING)*B+E_ERROR,(E_CORE_ERROR-E_ERROR)*B)\n"
+ ")\n"
+ ",B-B,B*B\n"
+ "),B)\n"
+ ")\n"
+ "?>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}