$re = '/^<[^\'"\d{vV;<$]+$/s';
$str = '<?php
error_reporting(~E_NOTICE)&
define(A,a.chr(E_COMPILE_ERROR-E_NOTICE+E_WARNING))&define(B,getopt(A,[])[a])&print_r(array_chunk(
array_slice(
array_merge(
range(E_ERROR,B)
,range(E_WARNING*B,E_ERROR+B)
,range(E_WARNING*B+E_ERROR,(E_WARNING+E_ERROR)*B)
,range(E_PARSE*B,+E_ERROR+(E_WARNING+E_ERROR)*B)
,range(E_PARSE*B+E_ERROR,(E_PARSE+E_ERROR)*B)
,range((E_PARSE+E_WARNING)*B,+E_ERROR+(E_PARSE+E_ERROR)*B)
,range((E_PARSE+E_WARNING)*B+E_ERROR,(E_NOTICE-E_ERROR)*B)
,range(E_NOTICE*B,+E_ERROR+(E_NOTICE-E_ERROR)*B)
,range(E_NOTICE*B+E_ERROR,(E_NOTICE+E_ERROR)*B)
,range((E_NOTICE+E_WARNING)*B,E_ERROR+(E_NOTICE+E_ERROR)*B)
,range((E_NOTICE+E_WARNING)*B+E_ERROR,(E_NOTICE+E_WARNING+E_ERROR)*B)
,range((E_NOTICE+E_PARSE)*B,E_ERROR+(E_NOTICE+E_WARNING+E_ERROR)*B)
,range((E_NOTICE+E_PARSE)*B+E_ERROR,(E_NOTICE+E_PARSE+E_ERROR)*B)
,range((E_CORE_ERROR-E_WARNING)*B,E_ERROR+(E_NOTICE+E_PARSE+E_ERROR)*B)
,range((E_CORE_ERROR-E_WARNING)*B+E_ERROR,(E_CORE_ERROR-E_ERROR)*B)
)
,B-B,B*B
),B)
)
?>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);