using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<[^'""\d{vV;<$]+$";
string input = @"<?php
error_reporting(~E_NOTICE)&
define(A,a.chr(E_COMPILE_ERROR-E_NOTICE+E_WARNING))&define(B,getopt(A,[])[a])&print_r(array_chunk(
array_slice(
array_merge(
range(E_ERROR,B)
,range(E_WARNING*B,E_ERROR+B)
,range(E_WARNING*B+E_ERROR,(E_WARNING+E_ERROR)*B)
,range(E_PARSE*B,+E_ERROR+(E_WARNING+E_ERROR)*B)
,range(E_PARSE*B+E_ERROR,(E_PARSE+E_ERROR)*B)
,range((E_PARSE+E_WARNING)*B,+E_ERROR+(E_PARSE+E_ERROR)*B)
,range((E_PARSE+E_WARNING)*B+E_ERROR,(E_NOTICE-E_ERROR)*B)
,range(E_NOTICE*B,+E_ERROR+(E_NOTICE-E_ERROR)*B)
,range(E_NOTICE*B+E_ERROR,(E_NOTICE+E_ERROR)*B)
,range((E_NOTICE+E_WARNING)*B,E_ERROR+(E_NOTICE+E_ERROR)*B)
,range((E_NOTICE+E_WARNING)*B+E_ERROR,(E_NOTICE+E_WARNING+E_ERROR)*B)
,range((E_NOTICE+E_PARSE)*B,E_ERROR+(E_NOTICE+E_WARNING+E_ERROR)*B)
,range((E_NOTICE+E_PARSE)*B+E_ERROR,(E_NOTICE+E_PARSE+E_ERROR)*B)
,range((E_CORE_ERROR-E_WARNING)*B,E_ERROR+(E_NOTICE+E_PARSE+E_ERROR)*B)
,range((E_CORE_ERROR-E_WARNING)*B+E_ERROR,(E_CORE_ERROR-E_ERROR)*B)
)
,B-B,B*B
),B)
)
?>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}