#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([a-zA-Z]+[0-9a-zA-Z]*?)(?:[0-9]+|[A-Z]*)\b.*"
Local $sString = "FAF46ABC7787AAAA" & @CRLF & _
"FAF46ABC7787" & @CRLF & _
"FAF46ABC" & @CRLF & _
"FAF46" & @CRLF & _
"FAF" & @CRLF & _
"FAF46 GG" & @CRLF & _
"FAF46.doc"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)