use strict;
my $str = 'FAF46ABC7787AAAA
FAF46ABC7787
FAF46ABC
FAF46
FAF
FAF46 GG
FAF46.doc';
my $regex = qr/^([a-zA-Z]+[0-9a-zA-Z]*?)(?:[0-9]+|[A-Z]*)\b.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";