using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]+[0-9a-zA-Z]*?)(?:[0-9]+|[A-Z]*)\b.*";
string substitution = @"$1";
string input = @"FAF46ABC7787AAAA
FAF46ABC7787
FAF46ABC
FAF46
FAF
FAF46 GG
FAF46.doc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}