package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]+[0-9a-zA-Z]*?)(?:[0-9]+|[A-Z]*)\b.*`)
var str = `FAF46ABC7787AAAA
FAF46ABC7787
FAF46ABC
FAF46
FAF
FAF46 GG
FAF46.doc`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}