$re = '/^([a-zA-Z]+[0-9a-zA-Z]*?)(?:[0-9]+|[A-Z]*)\b.*/m';
$str = 'FAF46ABC7787AAAA
FAF46ABC7787
FAF46ABC
FAF46
FAF
FAF46 GG
FAF46.doc';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;