using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\[?([\w$#]+)]?\.)?\[?([\w$#]+)]?$";
string input = @"-- should match
schema1.MyProcedure
MyProcedure
[MyProcedure]
[schema1].[MyProcedure]
[schema1].MyProcedure
MyProcedure_V1234
[MyProcedure_Ver1234]
schema1.[MyProcedure#V1234]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}