import Foundation
let pattern = ##"^(?:\[?([\w$#]+)]?\.)?\[?([\w$#]+)]?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
-- should match
schema1.MyProcedure
MyProcedure
[MyProcedure]
[schema1].[MyProcedure]
[schema1].MyProcedure
MyProcedure_V1234
[MyProcedure_Ver1234]
schema1.[MyProcedure#V1234]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)